[Cosmos Hub] - Degraded Performance

Incident Report for Blockdaemon

Resolved

We are pleased to inform you that the issue affecting Cosmos Hub API nodes, full nodes, and archive nodes has been resolved, and the service is now fully operational.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve the matter.

If you have any further questions or concerns, please don’t hesitate to reach out to your Customer Success Manager!

Thank you for your understanding!
Posted Sep 09, 2026 - 18:16 UTC

Identified

We have identified an issue affecting our Cosmos Hub API nodes, full nodes, and archive nodes following a recent network upgrade. Our team has identified the root cause and is actively working on recovery. We will post updates as they become available.

We apologize for the inconvenience and appreciate your patience and understanding. If you have any questions or concerns, please reach out to your Customer Success Manager.
Posted Sep 08, 2026 - 23:21 UTC
This incident affected: Blockdaemon RPC API (Cosmos Native API) and Protocols (Dedicated Nodes) (Cosmos).